This is an old revision of the document!
Table of Contents
Routage
Routage Interne
RIPng
OSPFv3
IS-IS
Le routeur de la zone 1 est défini en tant que routeur de level 1 car il échange uniquement ses routes avec des routeurs d'autres zones (routage interzone). Le routeur de la zone 2 est défini comme routeur de level 1 et level 2 car il est chargé à la fois du routage interzone entre les zones 1 et 2 et du routage intrazone pour la zone 2.
Une particularité de IS-IS est qu’il n’utilise pas IP comme protocole réseau pour l'échange de ces messages. Il faut ainsi affecter une adresse ISO NET (Network Entity Title [4]) à chaque routeur impliqué dans le processus de routage IS-IS. Le format de cet adressage est le suivant :
Les 3 premiers octets font donc référence à l’identifiant de zone. 00.0781. Les 6 octets suivant permettent d’identifier l’équipement dans la zone. Il est préconisé d’utiliser l’adresse MAC (Medium Access Contrôle) pour cet identifiant. Finalement le dernier octet doit toujours être positionné à 0x00 pour une utilisation de cet adressage avec IS-IS. Il est important de souligner que l’adresse NET est assignée au routeur et non à l’une de ses interfaces.
2 – Mise en œuvre (Cisco)
Voici les versions minimums requises pour pouvoir bénéficier du protocole de routage IS-IS dans l’IOS Cisco :
| Disponibilité dans l'IOS | 12.2(8)T, 12.0(21)ST, 12.0(22)S, 12.2(14)S, 12.3, 12.3(2)T, 12.4, 12.4(2)T |
|---|---|
| Version utilisée | 12.3(14)T, 12.2(18)S9 |
L’IOS Cisco propose deux approches différentes pour la mise en place d’IS-IS :
- single topology : toutes les interfaces utilisées dans IS-IS et pour un domaine donné doivent être configurées avec les mêmes familles d'adresses réseaux (IPv6, IPv4, …).
- multi topology : ce mode supprime la restriction précédente et permet ainsi de gérer des topologies de réseaux différentes pour les divers protocoles (IPv6, IPv4, …).
Dans l’exemple de configuration qui suit nous considèrerons que le protocole IS-IS est uniquement utilisé pour le routage IPv6 (→ single topology) comme cela est le cas sur le réseau StanNet.
Configuration d'IS-IS pour IPv6 [5]
Si cela n'est pas encore fait, la première étape consiste à activer le routage unicast IPv6 en mode de configuration globale du routeur.
Router(config)# ipv6 unicast-routing
Il est alors possible de définir un processus de routage IS-IS et ainsi rentrer dans le mode de configuration router qui va nous permettre de définir le comportement de ce processus de routage.
Router(config)# router isis stannet Router(config-router)#
Comme nous venons de le préciser dans la rapide présentation du protocole, IS-IS utilise un adressage ISO. C'est pourquoi il est nécessaire de définir l'adresse NET (Network Entity Title) qui sera utilisée pour identifier le routeur. L’adresse est donc composée du numéro de zone (00.0781), de l’identifiant de l’équipement dans la zone (0013.c32c.91a8 = adresse MAC) et du suffixe 0x00.
Router(config-router)# net 00.0781.0013.c32c.91a8.00
Il est également important de préciser le niveau IS-IS du routeur configuré. Si vous choisissez de définir une seule zone (ou domaine de routage) IS-IS alors le routeur devra appartenir au level 1.
Router(config-router)# is-type level-1
Nous allons maintenant définir les routes qui doivent être annoncées par le routeur IS-IS. Dans l'exemple qui suit les routes concernant les réseaux directement connectés seront redistribuées dans le protocole IS-IS.
Router(config-router)# address-family ipv6 Router(config-router-af)# redistribute connected level-1
A ce niveau, il est également possible de redistribuer par exemple dans IS-IS une route par défaut définit statiquement sur un des routeurs.
Router(config-router-af)# redistribute static level-1
Finalement la dernière étape consiste à activer le processus de routage sur l’ensemble des interfaces concernées :
Router(config)# interface FastEthernet 0/0.106 Router(config-if)# ipv6 router isis stannet
Une fois la configuration des routeurs terminée, il peut être intéressant de s’assurer que le comportement général est satisfaisant. Il existe pour cela un certain nombre de commandes indispensables.
Router# show isis topology
Cette commande permet de connaître l’ensemble des routeurs IS-IS pour toutes les zones du système autonome.
Router# show clns is-neighbors detail
Cette commande affiche les voisins connus par le routeur.
Router# show ipv6 route isis
Cette commande affiche l’ensemble des routes pour les réseaux IPv6 apprises grâce au protocole IS-IS.
Router# show isis ipv6 rib
Conclusion
La mise en oeuvre d’IS-IS pour IPv6 sur StanNet s’est avérée satisfaisante. Il faudra cependant certainement attendre un déploiement d’IPv6 à plus grande échelle pour évaluer les performances et les limites de ce dernier. Les principaux problèmes rencontrés ont concerné la disponibilité d’IS-IS sur certains IOS Cisco.
Références
RFC :
[1] RFC 2080 : RIPng for IPv6
[2] RFC 2740 : OSPF for IPv6
[3] RFC 1142 : OSI IS-IS Intra-domain Routing Protocol
[4] RFC 994 : Protocol for Providing the Connectionless-mode Network Service
Documents :
[5] Implementing IPv6 for Cisco IOS Software http://www.cisco.com/application/pdf/en/us/guest/products/ps5187/c2001/ccmigration_09186a00801d7f16.pdf
Sites Internet :
Introduction au protocole de routage IS-IS http://www.labo-cisco.com/ArticleComp.asp?ARID=61
Statique
Exemple de mise en oeuvre à Paris 1
Le réseau de l'université comporte dix sites RAP (réseau académique parisien) haut débit, ainsi que des « petits » sites en cascade, pour un total de vingt-quatre implantations, susceptible d'évoluer.
Extrait de la configuration du routeur Cisco 7301 du site Saint-Charles (raccordé au RAP haut débit)
interface Loopback0 ip address 194.214.30.9 255.255.255.255 ! interface Tunnel1 description *** Tunnel vers PMF *** ip address 10.1.12.91 255.255.255.0 ipv6 address 2001:660:3305:FF08::B/64 ip mtu 1476 tunnel source Loopback0 tunnel destination 194.214.30.1 ! route vers l'autre extrémité du tunnel via RAP ip route 194.214.30.1 255.255.255.255 195.221.125.197 ip route 0.0.0.0 0.0.0.0 Tunnel1 ipv6 route ::/0 Tunnel1
Extrait correspondant de la configuration du routeur Cisco 7200 VXR du site PMF (raccordé au RAP haut débit)
interface Loopback0 ip address 194.214.30.1 255.255.255.255 ! interface Tunnel12 description *** Tunnel vers Saint-Charles *** ip address 10.1.12.1 255.255.255.0 ipv6 address 2001:660:3305:FF08::A/64 ip mtu 1476 tunnel source Loopback0 tunnel destination 194.214.30.9 ! ! routes vers les réseaux de Saint Charles ipv6 route 2001:660:3305:80ff::/64 Tunnel12 ipv6 route 2001:660:3305:8001::/64 Tunnel12 ipv6 route 2001:660:3305:8030::/64 Tunnel12 ip route ...
Extrait de la configuration du commutateur Extreme Networks Summit 48si du site Arago (en cascade du site PMF via une LS 2 Mbit/s)
Le réseau d'interconnexion est le 2001:660:3305:ff /64.
# adresse IPv6 des interfaces et activation du routage IPv6 configure vlan arago-pers ipaddress ipv6 eui64 2001:660:3305:230::/64 enable ipforwarding ipv6 vlan arago-pers # route par défaut vers PMF configure iproute add ipv6 default 2001:660:3305:ff:20b:60ff:feb0:b006 1 # pour l'auto-configuration des postes de réseaux locaux enable router-discovery ipv6 arago-pers configure vlan arago-pers router-discovery ipv6 add prefix 2001:660:3305:230::/64
Extrait correspondant de la configuration du routeur Cisco 7200 VXR du site PMF (raccordé au RAP haut débit)
ipv6 route 2001:660:3305:0230::/64 2001:660:3305:ff:201:30ff:fe12:a5e0

