routage
Differences
This shows you the differences between two versions of the page.
| Both sides previous revisionPrevious revisionNext revision | Previous revision | ||
| routage [2005/11/15 10:52] – delove | routage [2019/01/22 11:18] (current) – external edit 127.0.0.1 | ||
|---|---|---|---|
| Line 6: | Line 6: | ||
| ==== IS-IS ==== | ==== IS-IS ==== | ||
| + | |||
| + | Ce document est également disponible en format PDF {{isis_cisco.pdf|IS-IS (Cisco)}} | ||
| === Introduction === | === Introduction === | ||
| Line 31: | Line 33: | ||
| L' | L' | ||
| - | {{isislevel.png}} | + | {{isislevel.png|Figure 1: Organisation hiérarchique}} |
| Le routeur de la zone 1 est défini en tant que routeur de level 1 car il échange uniquement ses routes avec des routeurs d' | Le routeur de la zone 1 est défini en tant que routeur de level 1 car il échange uniquement ses routes avec des routeurs d' | ||
| Une particularité de IS-IS est qu’il n’utilise pas IP comme protocole réseau pour l' | Une particularité de IS-IS est qu’il n’utilise pas IP comme protocole réseau pour l' | ||
| + | |||
| + | {{isisadressesnet.png|Figure 2 : Format d'une adresse ISO NET}} | ||
| + | |||
| + | Les 3 premiers octets font donc référence à l’identifiant de zone. 00.0781. Les 6 octets suivant permettent d’identifier l’équipement dans la zone. Il est préconisé d’utiliser l’adresse MAC (Medium Access Contrôle) pour cet identifiant. Finalement le dernier octet doit toujours être positionné à 0x00 pour une utilisation de cet adressage avec IS-IS. | ||
| === 2 – Mise en œuvre (Cisco) === | === 2 – Mise en œuvre (Cisco) === | ||
| + | |||
| + | Voici les versions minimums requises pour pouvoir bénéficier du protocole de routage IS-IS dans l’IOS Cisco : | ||
| + | |||
| + | ^ Disponibilité dans l' | ||
| + | ^ Version utilisée | ||
| + | |||
| + | L’IOS Cisco propose deux approches différentes pour la mise en place d’IS-IS : | ||
| + | |||
| + | * single topology : toutes les interfaces utilisées dans IS-IS et pour un domaine donné doivent être configurées avec les mêmes familles d' | ||
| + | * multi topology : ce mode supprime la restriction précédente et permet ainsi de gérer des topologies de réseaux différentes pour les divers protocoles (IPv6, IPv4, …). | ||
| + | |||
| + | Dans l’exemple de configuration qui suit nous considèrerons que le protocole IS-IS est uniquement utilisé pour le routage IPv6 (→ single topology) comme cela est le cas sur le réseau StanNet. | ||
| + | |||
| + | == Configuration d' | ||
| + | |||
| + | Si cela n'est pas encore fait, la première étape consiste à activer le routage unicast IPv6 en mode de configuration globale du routeur. | ||
| + | |||
| + | Router(config)# | ||
| + | |||
| + | Il est alors possible de définir un processus de routage IS-IS et ainsi rentrer dans le mode de configuration router qui va nous permettre de définir le comportement de ce processus de routage. | ||
| + | |||
| + | Router(config)# | ||
| + | Router(config-router)# | ||
| + | |||
| + | Comme nous venons de le préciser dans la rapide présentation du protocole, IS-IS utilise un adressage ISO. C'est pourquoi il est nécessaire de définir l' | ||
| + | |||
| + | Router(config-router)# | ||
| + | |||
| + | Il est également important de préciser le niveau IS-IS du routeur configuré. Si vous choisissez de définir une seule zone (ou domaine de routage) IS-IS alors le routeur devra appartenir au level 1. | ||
| + | |||
| + | Router(config-router)# | ||
| + | |||
| + | Nous allons maintenant définir les routes qui doivent être annoncées par le routeur IS-IS. Dans l' | ||
| + | |||
| + | Router(config-router)# | ||
| + | Router(config-router-af)# | ||
| + | |||
| + | A ce niveau, il est également possible de redistribuer par exemple dans IS-IS une route par défaut | ||
| + | |||
| + | Router(config-router-af)# | ||
| + | |||
| + | Finalement la dernière étape consiste à activer le processus de routage sur l’ensemble des interfaces concernées : | ||
| + | |||
| + | Router(config)# | ||
| + | Router(config-if)# | ||
| + | |||
| + | Une fois la configuration des routeurs terminée, il peut être intéressant de s’assurer que le comportement général est satisfaisant. Il existe pour cela un certain nombre de commandes indispensables. | ||
| + | |||
| + | Router# show isis topology | ||
| + | |||
| + | Cette commande permet de connaître l’ensemble des routeurs IS-IS pour toutes les zones du système autonome. | ||
| + | |||
| + | Router# show clns is-neighbors detail | ||
| + | |||
| + | Cette commande affiche les voisins connus par le routeur. | ||
| + | |||
| + | Router# show ipv6 route isis | ||
| + | |||
| + | Cette commande affiche l’ensemble des routes pour les réseaux IPv6 apprises grâce au protocole IS-IS. | ||
| + | |||
| + | Router# show isis ipv6 rib | ||
| === Conclusion | === Conclusion | ||
| + | |||
| + | La mise en oeuvre d’IS-IS pour IPv6 sur StanNet s’est avérée satisfaisante. Il faudra cependant certainement attendre un déploiement d’IPv6 à plus grande échelle pour évaluer les performances et les limites de ce dernier. Les principaux problèmes rencontrés ont concerné la disponibilité d’IS-IS sur certains IOS Cisco. | ||
| === Références === | === Références === | ||
| + | |||
| + | __RFC__ : | ||
| + | |||
| + | [1] RFC 2080 : RIPng for IPv6 | ||
| + | |||
| + | [2] RFC 2740 : OSPF for IPv6 | ||
| + | |||
| + | [3] RFC 1142 : OSI IS-IS Intra-domain Routing Protocol | ||
| + | |||
| + | [4] RFC 994 : Protocol for Providing the Connectionless-mode Network Service | ||
| + | |||
| + | __Documents__ : | ||
| + | |||
| + | [5] Implementing IPv6 for Cisco IOS Software | ||
| + | http:// | ||
| + | |||
| + | |||
| + | __Sites Internet__ : | ||
| + | |||
| + | Introduction au protocole de routage IS-IS | ||
| + | http:// | ||
| ==== Statique ==== | ==== Statique ==== | ||
routage.1132051928.txt.gz · Last modified: (external edit)
