User Tools

Site Tools


routage

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
routage [2005/11/08 10:06] – chopardroutage [2019/01/22 11:18] (current) – external edit 127.0.0.1
Line 4: Line 4:
 ==== RIPng ==== ==== RIPng ====
 ==== OSPFv3 ==== ==== OSPFv3 ====
 +
 ==== IS-IS ==== ==== IS-IS ====
 +
 + Ce document est également disponible en format PDF {{isis_cisco.pdf|IS-IS (Cisco)}}
 +
 +=== Introduction ===
 +
 +La rédaction de cette documentation s’inscrit dans le cadre du projet IPv6-ADIRE qui vise à déployer IPv6 sur les réseaux de production de l’enseignement supérieur et de la recherche. Dans ce contexte le choix d’un protocole de routage adapté est une étape inévitable pour permettre un déploiement à grande échelle.
 +
 +Il existe à l'heure actuelle un certain nombre de protocole de routage interne (IGP) pour IPv6 :
 +
 +  * RIPng [1] : Routing Information Protocol new generation
 +  * OSPFv3 [2] : Open Shortest Path First version 3
 +  * Integrated IS-IS [3] : Intermediate System to Intermediate System 
 +
 +
 +OSPFv3 et RIPng sont respectivement les adaptations pour IPv6 des protocoles OSPFv2 et RIPv2. Leur mise en oeuvre nécessite donc le choix d’un second protocole pour la gestion du routage IPv4. IS-IS se démarque en offrant la possibilité de gérer plusieurs protocoles simultanément (exemple : IPv6 et IPv4). Ce document présente dans sa première partie les concepts principaux d’IS-IS en pointant sur les références nécessaires pour une compréhension plus approfondie. La seconde partie sera dédiée à la mise en œuvre de ce protocole sur un routeur Cisco. 
 +
 +=== 1 – Présentation d’IS-IS ===  
 +
 +IS-IS est comme OSPF un protocole interne de routage à états de liens. Cela signifie que chaque routeur transmet l'état de ses liaisons dans le but de dresser une carte de l'état du réseau puis de construire sa table de routage. Ce modèle de fonctionnement est à opposer aux protocoles à vecteur de distance comme RIP. Comme OSPF, IS-IS est également un protocole de routage hiérarchique permettant de définir plusieurs domaines (zones = Intermediate System) de routage et ainsi réduire la taille des tables ainsi que le temps de convergence.
 +
 +Un routeur IS-IS peut appartenir aux types suivants :  
 +
 +  * level 1 : pour le routage intrazone.  Un routeur de niveau 1 n’échange des messages qu’à l’intérieur de la zone où il est défini.
 +  * level 2 : pour le routage interzone.  Un routeur de niveau 2 est chargé de l’échange des routes entre plusieurs zones.
 +
 +L'exemple qui suit permet d'illustrer ces deux niveaux de fonctionnement : 
 +
 +{{isislevel.png|Figure 1: Organisation hiérarchique}}
 +
 +Le routeur de la zone 1 est défini en tant que routeur de level 1 car il échange uniquement ses routes avec des routeurs d'autres zones (routage interzone). Le routeur de la zone 2 est défini comme routeur de level 1 et level 2 car il est chargé à la fois du routage interzone entre les zones 1 et 2 et du routage intrazone pour la zone 2.
 +
 +Une particularité de IS-IS est qu’il n’utilise pas IP comme protocole réseau pour l'échange de ces messages. Il faut ainsi affecter une adresse ISO NET (Network Entity Title [4]) à chaque routeur impliqué dans le processus de routage IS-IS. Le format de cet adressage est le suivant :
 +
 +{{isisadressesnet.png|Figure 2 : Format d'une adresse ISO NET}}
 +
 +Les 3 premiers octets font donc référence à l’identifiant de zone. 00.0781. Les 6 octets suivant permettent d’identifier l’équipement dans la zone. Il est préconisé d’utiliser l’adresse MAC (Medium Access Contrôle) pour cet identifiant. Finalement le dernier octet doit toujours être positionné à 0x00 pour une utilisation de cet adressage avec IS-IS.  Il est important de souligner que l’adresse NET est assignée au routeur et non à l’une de ses interfaces.
 +
 +=== 2 – Mise en œuvre (Cisco) ===
 +
 +Voici les versions minimums requises pour pouvoir bénéficier du protocole de routage IS-IS dans l’IOS Cisco : 
 +
 +^ Disponibilité dans l'IOS   | 12.2(8)T, 12.0(21)ST, 12.0(22)S, 12.2(14)S, 12.3, 12.3(2)T, 12.4, 12.4(2)T |
 +^ Version utilisée           | 12.3(14)T, 12.2(18)S9 |
 +
 +L’IOS Cisco propose deux approches différentes pour la mise en place d’IS-IS : 
 +
 +  * single topology : toutes les interfaces utilisées dans IS-IS et pour un domaine donné doivent être configurées avec les mêmes familles d'adresses réseaux (IPv6, IPv4, ...).
 +  * multi topology : ce mode supprime la restriction précédente et permet ainsi de gérer des topologies de réseaux différentes pour les divers protocoles (IPv6, IPv4, …).
 +
 +Dans l’exemple de configuration qui suit nous considèrerons que le protocole IS-IS est uniquement utilisé pour le routage IPv6 (→ single topology) comme cela est le cas sur le réseau StanNet.
 +
 +== Configuration d'IS-IS pour IPv6 [5] ==
 +
 +Si cela n'est pas encore fait, la première étape consiste à activer le routage unicast IPv6 en mode de configuration globale du routeur.
 +
 +  Router(config)# ipv6 unicast-routing
 +
 +Il est alors possible de définir un processus de routage IS-IS et ainsi rentrer dans le mode de configuration router qui va nous permettre de définir le comportement de ce processus de routage.
 +
 +  Router(config)# router isis stannet
 +  Router(config-router)#
 +
 +Comme nous venons de le préciser dans la rapide présentation du protocole, IS-IS utilise un adressage ISO. C'est pourquoi il est nécessaire de définir l'adresse NET (Network Entity Title) qui sera utilisée pour identifier le routeur. L’adresse est donc composée du numéro de zone (00.0781), de l’identifiant de l’équipement dans la zone (0013.c32c.91a8 = adresse MAC) et du suffixe 0x00.
 +
 +  Router(config-router)# net 00.0781.0013.c32c.91a8.00 
 +
 +Il est également important de préciser le niveau IS-IS du routeur configuré. Si vous choisissez de définir une seule zone (ou domaine de routage) IS-IS alors le routeur devra appartenir au level 1.   
 +
 +  Router(config-router)# is-type level-1 
 +
 +Nous allons maintenant définir les routes qui doivent être annoncées par le routeur IS-IS. Dans l'exemple qui suit les routes concernant les réseaux directement connectés seront redistribuées dans le protocole IS-IS.
 +
 +  Router(config-router)# address-family ipv6
 +  Router(config-router-af)# redistribute connected level-1 
 +
 +A ce niveau, il est également possible de redistribuer par exemple dans IS-IS une route par défaut  définit statiquement sur un des routeurs.
 +
 +  Router(config-router-af)# redistribute static level-1 
 +
 +Finalement la dernière étape consiste à activer le processus de routage sur l’ensemble des interfaces concernées : 
 +
 +  Router(config)# interface FastEthernet 0/0.106
 +  Router(config-if)# ipv6 router isis stannet 
 +
 +Une fois la configuration des routeurs terminée, il peut être intéressant de s’assurer que le comportement général est satisfaisant. Il existe pour cela un certain nombre de commandes indispensables.
 +
 +  Router# show isis topology
 +
 +Cette commande permet de connaître l’ensemble des routeurs IS-IS pour toutes les zones du système autonome.
 +
 +  Router# show clns is-neighbors detail
 +
 +Cette commande affiche les voisins connus par le routeur.
 +
 +  Router# show ipv6 route isis
 +
 +Cette commande affiche l’ensemble des routes pour les réseaux IPv6 apprises grâce au protocole IS-IS.
 +
 +  Router# show isis ipv6 rib
 +
 +=== Conclusion  ===
 +
 +La mise en oeuvre d’IS-IS pour IPv6 sur StanNet s’est avérée satisfaisante. Il faudra cependant certainement attendre un déploiement d’IPv6 à plus grande échelle pour évaluer les performances et les limites de ce dernier. Les principaux problèmes rencontrés ont concerné la disponibilité d’IS-IS sur certains IOS Cisco. 
 +
 +=== Références ===
 +
 +__RFC__ : 
 +
 +[1] RFC 2080 : RIPng for IPv6
 +
 +[2] RFC 2740 : OSPF for IPv6
 +
 +[3] RFC 1142 : OSI IS-IS Intra-domain Routing Protocol
 +
 +[4] RFC 994 : Protocol for Providing the Connectionless-mode Network Service
 +
 +__Documents__ : 
 +
 +[5] Implementing IPv6 for Cisco IOS Software
 +http://www.cisco.com/application/pdf/en/us/guest/products/ps5187/c2001/ccmigration_09186a00801d7f16.pdf
 +
 +
 +__Sites Internet__ : 
 +
 +Introduction au protocole de routage IS-IS
 +http://www.labo-cisco.com/ArticleComp.asp?ARID=61
  
 ==== Statique ==== ==== Statique ====
Line 65: Line 192:
 enable router-discovery ipv6 arago-pers enable router-discovery ipv6 arago-pers
 configure vlan arago-pers router-discovery ipv6 add prefix 2001:660:3305:230::/64 configure vlan arago-pers router-discovery ipv6 add prefix 2001:660:3305:230::/64
-routes vers les VLANs de ce site sur le Cisco de PMF :+</file> 
 + 
 +== Extrait correspondant de la configuration du routeur Cisco 7200 VXR du site PMF (raccordé au RAP haut débit) == 
 + 
 +<file>
 ipv6 route 2001:660:3305:0230::/64 2001:660:3305:ff:201:30ff:fe12:a5e0 ipv6 route 2001:660:3305:0230::/64 2001:660:3305:ff:201:30ff:fe12:a5e0
 </file> </file>
routage.1131444389.txt.gz · Last modified: (external edit)