dns
Differences
This shows you the differences between two versions of the page.
| Both sides previous revisionPrevious revisionNext revision | Previous revision | ||
| dns [2005/11/15 12:28] – delove | dns [2019/01/22 11:18] (current) – external edit 127.0.0.1 | ||
|---|---|---|---|
| Line 38: | Line 38: | ||
| ===== DNS dynamiques ===== | ===== DNS dynamiques ===== | ||
| - | Ce document est également disponible au format PDF {{ddns_v6.pdf}} | + | Ce document est également disponible au format PDF {{ddns_v6.pdf|DNS dynamiques}} |
| ==== Introduction ==== | ==== Introduction ==== | ||
| Line 107: | Line 107: | ||
| Algorithm: 157 (HMAC_MD5) | Algorithm: 157 (HMAC_MD5) | ||
| Key: wMkRFcweTFSBwlbWDaoF0w== | Key: wMkRFcweTFSBwlbWDaoF0w== | ||
| - | |||
| ==== Configuration d'un poste client ==== | ==== Configuration d'un poste client ==== | ||
| + | |||
| + | Il est maintenant nécessaire de copier le fichier contenant la clé privée (.private) et généré sur le serveur par le biais de la commande dnssec-keygen sur le poste client. Cette copie devra être sécurisée afin d' | ||
| + | |||
| + | La commande qui permet de réaliser les “updates” dynamiques sur un poste Linux est nsupdate. Son fonctionnement est très simple : | ||
| + | |||
| + | # nsupdate -k ./ | ||
| + | Creating key... | ||
| + | > update delete host1.postes.ipv6.ciril.fr | ||
| + | > update add host1.postes.ipv6.ciril.fr 60 IN AAAA < | ||
| + | > send | ||
| + | |||
| + | Cette séquence permet d' | ||
| + | |||
| + | L' | ||
| + | |||
| + | < | ||
| + | #!/bin/sh | ||
| + | HOSTNAME=`hostname` | ||
| + | DOMAIN=postes.ipv6.ciril.fr | ||
| + | IPADDR=`/ | ||
| + | echo " | ||
| + | echo " | ||
| + | for i in $IPADDR | ||
| + | do | ||
| + | echo " | ||
| + | done | ||
| + | |||
| + | echo "" | ||
| + | / | ||
| + | </ | ||
| + | |||
| + | La directive prereq nxrrset permet de tester la non préexistence d’une ressource possédant le même nom. En d' | ||
| + | |||
| + | Les enregistrements dynamiques n' | ||
| + | |||
| + | __Remarque__ : À la rédaction de cette documentation, | ||
| ==== Conclusion ==== | ==== Conclusion ==== | ||
| + | |||
| + | L’inconvénient majeur de la mise en oeuvre d'un mécanisme de Dynamic DNS réside dans le fait qu’aucun système d’exploitation ne permet à l’heure actuelle de réaliser cette tâche directement du côté client. Cette extension du service DNS sensée faciliter la tâche d’administration s' | ||
| ==== Références ==== | ==== Références ==== | ||
| + | __RFC__ : | ||
| + | |||
| + | [1] RFC 2136 - Dynamic Updates in the Domain Name System (DNS UPDATE) | ||
| + | |||
| + | [2] RFC 2137 - Secure Domain Name System Dynamic Update | ||
| + | |||
| + | [4] RFC 2845 - Secret Key Transaction Authentication for DNS (TSIG) | ||
| + | |||
| + | __Documents__ : | ||
| + | |||
| + | [5] draft : The DHCPv6 Client FQDN Option | ||
| + | |||
| + | |||
| + | __Sites Internet__ : | ||
| + | |||
| + | [3] BIND (Berkeley Internet Name Domain) | ||
| + | http:// | ||
| + | [6] Dibbler - a portable DHCPv6 | ||
| + | http:// | ||
dns.1132057736.txt.gz · Last modified: (external edit)
